FreeTextBoxControls

FreeTextBox 1.6.x

FreeTextBoxControls Namespace

Classes

Class | Description
FreeTextBox | An HTML editor using MSHTML written for ASP.NET.
ScrollbarStyle | Contains all the style parameters for ToolbarButtons
Toolbar | A Toolbar for FreeTextBox
ToolbarButton | A button used in an Toolbar
ToolbarButtonStyle | Contains all the style parameters for ToolbarButtons
ToolbarDropDownList | A DropDownList for a Toolbar
ToolbarGenerator | Builds Toolbars and ToolbarItems from strings
ToolbarItem | Abstract class for all toolbar items
ToolbarItems | Contains all the built-in ToolbarButtons and ToolbarDropDownLists
ToolbarListItem | A DropDownList Item for a Toolbar
ToolbarSeparator | Creates a separator bar in a Toolbar

Enumerations

Enumeration | Description
AutoConfigure | Several predefined sets of buttons
BreakMode | Determines what happens when the "enter" key is pressed in the editor
ButtonTitleMode | Determines how or if titles are displayed on buttons
ButtonType | Determines how buttons are drawn
DownlevelMode | Determines what is displayed for Downlevel browsers
EditorMode | Determines which mode the editor is in
HtmlMode | Determines what type of interface is displayed for switching between HtmlMode and DesignMode
PasteMode | Determines what happens when a user pastes into the control
ScrollbarMode | Determines the style of the scroll bar.
ToolbarType | Determines how the toolbars and its buttons and dropdownlists are displayed

Copyright John Dyer 2003


AutoConfigure Enumeration

Several predefined sets of buttons

public enum AutoConfigure

Members

Member Name | Description
Default | Uses the default string of buttons
Minimal | Enables only a few buttons
EnableAll | Enables all buttons and dropdowns
Alternate | Any alternate layout that emphasizes the save button and color pickers

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace

Copyright John Dyer 2003

Generated from assembly FreeTextBox [1.6.3.26073]


BreakMode Enumeration

Determines what happens when the "enter" key is pressed in the editor

public enum BreakMode

Members

Member Name | Description
LineBreak | Enter key inserts <br>
ParagraphBreak | Enter key inserts new paragraph, Ctrl+Enter inserts <br>

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


ButtonTitleMode Enumeration

Determines how or if titles are displayed on buttons

public enum ButtonTitleMode

Members

Member Name | Description
None | No button titles are displayed. Overrides ToolbarButton.TitleVisible
Selective | Button Titles are only show if the buttons TitleVisible property is true
All | All button titles are shown

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


ButtonType Enumeration

Determines how buttons are drawn

public enum ButtonType

Members

Member Name | Description
Image | Uses images for buttons. Button borders and backcolors default to Office XP style
FormButton | Uses HTML <input type="button"> for ToolbarButtons

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


DownlevelMode Enumeration

Determines what is displayed for Downlevel browsers

public enum DownlevelMode

Members

Member Name | Description
BasicEditor | A basic editor consisting of a normal TEXTAREA with a WYSISYG Div
Document | Displays the HTML inline with no form control
Message | Outputs a predefined message
TextArea | Outputs a standard HTML textarea

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


EditorMode Enumeration

Determines which mode the editor is in

public enum EditorMode

Members

Member Name | Description
HtmlMode | HTML editing mode
DesignMode | What you see is what you get design mode

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


FreeTextBox Class

An HTML editor using MSHTML written for ASP.NET.

For a list of all members of this type, see FreeTextBox Members.

System.Object
Control
FreeTextBox

public class FreeTextBox : Control, IPostBackDataHandler, INamingContainer, IPostBackEventHandler

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox Members

Public Instance Constructors

FreeTextBox Constructor Initializes a new instance of the FreeTextBox class.

Public Instance Fields

Toolbars Collection of the toolbars

Public Instance Properties

AlertClientToChangesInDesignMode | When the user switches from Html to Design mode this will alert the user to possible changes or additions made by MSHTML. Default false.
AllowHtmlMode | Boolean value for whether the editor can go into HTML mode.
AutoConfigure | Autoconfigures the toolbar with a set of buttons.
AutoHideToolbar | Boolean value for whether the toolbars are hidden when the editor is in HTML mode.
BackColor | The back color of the entire editor area.
BindingContainer (inherited from Control) |
BreakMode | Whether the editor uses Paragraph tags or Line Breaks when Enter is pressed.
ButtonDownImage | Boolean for whether buttons change images onMouseDown.
ButtonDownStyle | Boolean for whether buttons change style (borders and back color) onMouseDown.
ButtonFileExtention | The file type extention of buttons (gif,jpg,png)
ButtonOverImage | Boolean for whether buttons change images onMouseOver.
ButtonOverStyle | Boolean for whether buttons change style (borders and back color) onMouseOver.
ButtonPath | The path to button images. Defaults to String.Empty, but is set but ButtonStyle
ButtonStyle | Style parameters for ToolbarButtons. Is unused if ButtonType is set to FormButton. If ToolbarType is manually set, these values may be overridden. You should set ToolbarType to ToolbarType.Custom when customizing ButtonStyle
ButtonTitleMode | Determines how button titles are displayed
ButtonType | Determines how buttons are displayed. Image is the default type.
ClientID (inherited from Control) |
Controls (inherited from Control) |
ConvertHtmlSymbolsToHtmlCodes | If true, strips out all the base
DesignModeCss | The URL of the style sheet used in Design mode.
DownlevelColumns | The columns of the textarea if DownlevelMode is set to TextArea
DownlevelMessage | The message displayed if DownlevelMode is set to Message.
DownlevelMode | Determines what is displayed when a non-UpLevel browser tries to use the editor.
DownlevelRows | The rows of the textarea if DownlevelMode is set to TextArea
EditorBorderColorDark | The dark color of the border of the Editor window.
EditorBorderColorLight | The light color of the border of the Editor window.
EnableCurlyQuotes | Will insert curly quotes (using HTML codes “ and ”) in place of normal quotes. Default true.
EnableSsl | If true, sets IFRAME source so that SSL will work
EnableViewState (inherited from Control) |
FontBackColorsMenuList | A list of colors for the font back colors drop down.
FontBackColorsMenuNames | A list of color names for the font back colors drop down.
FontBackColorsMenuTitle | The title for the font back colors drop down.
FontFacesMenuList | A list of fonts for the font drop down.
FontFacesMenuTitle | The title for the font drop down.
FontForeColorsMenuList | A list of colors for the font fore colors drop down.
FontForeColorsMenuNames | A list of color names for the font fore colors drop down.
FontForeColorsMenuTitle | The title for the font fore colors drop down.
FontSizesMenuList | A list of fonts sizes the font sizes drop down.
FontSizesMenuTitle | The title for the font sizes drop down.
GutterBackColor | The back color of the gutter of the tab area.
GutterBorderColorDark | The dark color of the border of the Editor window.
GutterBorderColorLight | The light color of the border of the Editor window.
Height | The height of the editor including toolbars.
HelperFilesParameters | Parameters included with all helper scripts
HelperFilesPath | The path to helper files. Default is blank which will look in the current directory. Automatically affixes a "/" if it's not included.
HtmlEncodedText | Applies Server.HtmlEncode to Text. Please note that Server.HtmlEncode does not recognize all HTML characters.
HtmlMode | Determines what type of interface is used for HtmlMode
HtmlModeCss | The URL of the style sheet used in HTML mode.
HtmlModeDefaultsToMonoSpaceFont | The URL of the style sheet used in HTML mode.
HtmlStrippedText | Returns the Text property stripped of HTML, using Regex <(.|\n)+?>
ID (inherited from Control) |
ImageGalleryPath | The path to for the InsertImageFromGallery Button. Defaults to "images". Use forward slashes "/" and do not all leading or trailing slashes.
InsertHtmlMenuList | A list of HTML for the insert HTML drop down.
InsertHtmlMenuNames | A list of names for items in the insert HTML drop down.
InsertHtmlMenuTitle | The title for the insert HTML drop down.
IsBasicEditorCapable | Boolean value for the client's browser supports the Basic Editor
IsMshtmlEditorCapable | Boolean value for if the client supports FreeTextBox.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
ParagraphMenuList | A list of HTML values for the for the paragraph formatting drop down.
ParagraphMenuNames | A list of paragraph names for the paragraph formatting drop down.
ParagraphMenuTitle | The title for the paragraph formatting drop down.
Parent (inherited from Control) |
PasteMode | If true, does not allow pasting of text into FreeTextArea.
RawText | Outputs what is stored in the hidden HMTL field before any post processing
ReadOnly | If true, HTML is not editable.
RemoveScriptNameFromBookmarks | Removes the scriptname from bookmarks
RemoveServerNameFromUrls | If true, strips out the local server name from all A and IMG tags
ScrollbarMode | Determines whether Styles are applied to the scrollbar
ScrollbarStyle | Sets the style for the scrollbar
ShowStatusArea | Boolean value for whether the status area is shown when HtmlMode.Tabs is set.
Site (inherited from Control) |
StartMode | The rows of the textarea if DownlevelMode is set to TextArea
StyleMenuList | A list of styles for the style drop down.
StyleMenuNames | A list of style names for the style drop down.
StyleMenuTitle | The title for the styles drop down.
SymbolsMenuList | A list of HTML values for the symbols drop down.
SymbolsMenuTitle | The title for the symbols drop down.
TemplateSourceDirectory (inherited from Control) |
Text | Contains the HTML for the editor.
ToolbarBackColor | The back color of each toolbar.
ToolbarBackGroundImage | Uses the file toolbar.background file from the current image directory.
ToolbarLayout | A string of buttons used to create the toolbar. Use commas (,) to separate items. A semicolon (;) will insert a separator and a pipe (|) will start a new Toolbar. Possible values are ParagraphMenu, FontFacesMenu, FontSizesMenu, FontForeColorsMenu, FontForeColorPicker, FontBackColorsMenu, FontBackColorPicker, Bold, Italic, Underline, Strikethrough, Superscript, Subscript;InsertImageFromGallery, CreateLink, Unlink, RemoveFormat, JustifyLeft, JustifyRight, JustifyCenter, JustifyFull;BulletedList, NumberedList, Indent, Outdent, Cut, Copy, Paste, Delete;Undo, Redo, Print, Save, ieSpellCheck, StyleMenu, SymbolsMenu, InsertHtmlMenu, InsertRule, InsertDate, InsertTime, WordCount
ToolbarType | Sets the style for how the toolbar is draw.
UniqueID (inherited from Control) |
Visible (inherited from Control) |
Width | The width of the editor.

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) |
LoadPostData |
ProcessToolbarButton |
RaisePostBackEvent |
RaisePostDataChangedEvent |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
SaveClick | The event fired when a Save button is pressed.
Unload (inherited from Control) |

Protected Instance Properties

ChildControlsCreated (inherited from Control)
Context (inherited from Control)
Events (inherited from Control)
HasChildViewState (inherited from Control)
IsTrackingViewState (inherited from Control)
ViewState (inherited from Control)
ViewStateIgnoresCase (inherited from Control)

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit |
OnLoad |
OnPreRender |
OnSaveClick | Event for Save button
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
RegisterClientScript |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

FreeTextBox Class | FreeTextBoxControls Namespace


FreeTextBox Constructor

Initializes a new instance of the FreeTextBox class.

public FreeTextBox();

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox Fields

The fields of the FreeTextBox class are listed below. For a complete list of FreeTextBox class members, see the FreeTextBox Members topic.

Public Instance Fields

Toolbars Collection of the toolbars

See Also

FreeTextBox Class | FreeTextBoxControls Namespace


FreeTextBox.Toolbars Field

Collection of the toolbars

public ToolbarList Toolbars;

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox Properties

The properties of the FreeTextBox class are listed below. For a complete list of FreeTextBox class members, see the FreeTextBox Members topic.

Public Instance Properties

AlertClientToChangesInDesignMode | When the user switches from Html to Design mode this will alert the user to possible changes or additions made by MSHTML. Default false.
AllowHtmlMode | Boolean value for whether the editor can go into HTML mode.
AutoConfigure | Autoconfigures the toolbar with a set of buttons.
AutoHideToolbar | Boolean value for whether the toolbars are hidden when the editor is in HTML mode.
BackColor | The back color of the entire editor area.
BindingContainer (inherited from Control) |
BreakMode | Whether the editor uses Paragraph tags or Line Breaks when Enter is pressed.
ButtonDownImage | Boolean for whether buttons change images onMouseDown.
ButtonDownStyle | Boolean for whether buttons change style (borders and back color) onMouseDown.
ButtonFileExtention | The file type extention of buttons (gif,jpg,png)
ButtonOverImage | Boolean for whether buttons change images onMouseOver.
ButtonOverStyle | Boolean for whether buttons change style (borders and back color) onMouseOver.
ButtonPath | The path to button images. Defaults to String.Empty, but is set but ButtonStyle
ButtonStyle | Style parameters for ToolbarButtons. Is unused if ButtonType is set to FormButton. If ToolbarType is manually set, these values may be overridden. You should set ToolbarType to ToolbarType.Custom when customizing ButtonStyle
ButtonTitleMode | Determines how button titles are displayed
ButtonType | Determines how buttons are displayed. Image is the default type.
ClientID (inherited from Control) |
Controls (inherited from Control) |
ConvertHtmlSymbolsToHtmlCodes | If true, strips out all the base
DesignModeCss | The URL of the style sheet used in Design mode.
DownlevelColumns | The columns of the textarea if DownlevelMode is set to TextArea
DownlevelMessage | The message displayed if DownlevelMode is set to Message.
DownlevelMode | Determines what is displayed when a non-UpLevel browser tries to use the editor.
DownlevelRows | The rows of the textarea if DownlevelMode is set to TextArea
EditorBorderColorDark | The dark color of the border of the Editor window.
EditorBorderColorLight | The light color of the border of the Editor window.
EnableCurlyQuotes | Will insert curly quotes (using HTML codes “ and ”) in place of normal quotes. Default true.
EnableSsl | If true, sets IFRAME source so that SSL will work
EnableViewState (inherited from Control) |
FontBackColorsMenuList | A list of colors for the font back colors drop down.
FontBackColorsMenuNames | A list of color names for the font back colors drop down.
FontBackColorsMenuTitle | The title for the font back colors drop down.
FontFacesMenuList | A list of fonts for the font drop down.
FontFacesMenuTitle | The title for the font drop down.
FontForeColorsMenuList | A list of colors for the font fore colors drop down.
FontForeColorsMenuNames | A list of color names for the font fore colors drop down.
FontForeColorsMenuTitle | The title for the font fore colors drop down.
FontSizesMenuList | A list of fonts sizes the font sizes drop down.
FontSizesMenuTitle | The title for the font sizes drop down.
GutterBackColor | The back color of the gutter of the tab area.
GutterBorderColorDark | The dark color of the border of the Editor window.
GutterBorderColorLight | The light color of the border of the Editor window.
Height | The height of the editor including toolbars.
HelperFilesParameters | Parameters included with all helper scripts
HelperFilesPath | The path to helper files. Default is blank which will look in the current directory. Automatically affixes a "/" if it's not included.
HtmlEncodedText | Applies Server.HtmlEncode to Text. Please note that Server.HtmlEncode does not recognize all HTML characters.
HtmlMode | Determines what type of interface is used for HtmlMode
HtmlModeCss | The URL of the style sheet used in HTML mode.
HtmlModeDefaultsToMonoSpaceFont | The URL of the style sheet used in HTML mode.
HtmlStrippedText | Returns the Text property stripped of HTML, using Regex <(.|\n)+?>
ID (inherited from Control) |
ImageGalleryPath | The path to for the InsertImageFromGallery Button. Defaults to "images". Use forward slashes "/" and do not all leading or trailing slashes.
InsertHtmlMenuList | A list of HTML for the insert HTML drop down.
InsertHtmlMenuNames | A list of names for items in the insert HTML drop down.
InsertHtmlMenuTitle | The title for the insert HTML drop down.
IsBasicEditorCapable | Boolean value for the client's browser supports the Basic Editor
IsMshtmlEditorCapable | Boolean value for if the client supports FreeTextBox.
NamingContainer (inherited from Control) |
Page (inherited from Control) |
ParagraphMenuList | A list of HTML values for the for the paragraph formatting drop down.
ParagraphMenuNames | A list of paragraph names for the paragraph formatting drop down.
ParagraphMenuTitle | The title for the paragraph formatting drop down.
Parent (inherited from Control) |
PasteMode | If true, does not allow pasting of text into FreeTextArea.
RawText | Outputs what is stored in the hidden HMTL field before any post processing
ReadOnly | If true, HTML is not editable.
RemoveScriptNameFromBookmarks | Removes the scriptname from bookmarks
RemoveServerNameFromUrls | If true, strips out the local server name from all A and IMG tags
ScrollbarMode | Determines whether Styles are applied to the scrollbar
ScrollbarStyle | Sets the style for the scrollbar
ShowStatusArea | Boolean value for whether the status area is shown when HtmlMode.Tabs is set.
Site (inherited from Control) |
StartMode | The rows of the textarea if DownlevelMode is set to TextArea
StyleMenuList | A list of styles for the style drop down.
StyleMenuNames | A list of style names for the style drop down.
StyleMenuTitle | The title for the styles drop down.
SymbolsMenuList | A list of HTML values for the symbols drop down.
SymbolsMenuTitle | The title for the symbols drop down.
TemplateSourceDirectory (inherited from Control) |
Text | Contains the HTML for the editor.
ToolbarBackColor | The back color of each toolbar.
ToolbarBackGroundImage | Uses the file toolbar.background file from the current image directory.
ToolbarLayout | A string of buttons used to create the toolbar. Use commas (,) to separate items. A semicolon (;) will insert a separator and a pipe (|) will start a new Toolbar. Possible values are ParagraphMenu, FontFacesMenu, FontSizesMenu, FontForeColorsMenu, FontForeColorPicker, FontBackColorsMenu, FontBackColorPicker, Bold, Italic, Underline, Strikethrough, Superscript, Subscript;InsertImageFromGallery, CreateLink, Unlink, RemoveFormat, JustifyLeft, JustifyRight, JustifyCenter, JustifyFull;BulletedList, NumberedList, Indent, Outdent, Cut, Copy, Paste, Delete;Undo, Redo, Print, Save, ieSpellCheck, StyleMenu, SymbolsMenu, InsertHtmlMenu, InsertRule, InsertDate, InsertTime, WordCount
ToolbarType | Sets the style for how the toolbar is draw.
UniqueID (inherited from Control) |
Visible (inherited from Control) |
Width | The width of the editor.

Protected Instance Properties

ChildControlsCreated (inherited from Control)
Context (inherited from Control)
Events (inherited from Control)
HasChildViewState (inherited from Control)
IsTrackingViewState (inherited from Control)
ViewState (inherited from Control)
ViewStateIgnoresCase (inherited from Control)

See Also

FreeTextBox Class | FreeTextBoxControls Namespace


FreeTextBox.AlertClientToChangesInDesignMode Property

When the user switches from Html to Design mode this will alert the user to possible changes or additions made by MSHTML. Default false.

public bool AlertClientToChangesInDesignMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.AllowHtmlMode Property

Boolean value for whether the editor can go into HTML mode.

public bool AllowHtmlMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.AutoConfigure Property

Autoconfigures the toolbar with a set of buttons.

public AutoConfigure AutoConfigure {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.AutoHideToolbar Property

Boolean value for whether the toolbars are hidden when the editor is in HTML mode.

public bool AutoHideToolbar {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.BackColor Property

The back color of the entire editor area.

public System.Drawing.Color BackColor {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.BreakMode Property

Whether the editor uses Paragraph tags or Line Breaks when Enter is pressed.

public BreakMode BreakMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonDownImage Property

Boolean for whether buttons change images onMouseDown.

public bool ButtonDownImage {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonDownStyle Property

Boolean for whether buttons change style (borders and back color) onMouseDown.

public bool ButtonDownStyle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonFileExtention Property

The file type extention of buttons (gif,jpg,png)

public string ButtonFileExtention {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonOverImage Property

Boolean for whether buttons change images onMouseOver.

public bool ButtonOverImage {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonOverStyle Property

Boolean for whether buttons change style (borders and back color) onMouseOver.

public bool ButtonOverStyle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonPath Property

The path to button images. Defaults to String.Empty, but is set but ButtonStyle

public string ButtonPath {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonStyle Property

Style parameters for ToolbarButtons. Is unused if ButtonType is set to FormButton. If ToolbarType is manually set, these values may be overridden. You should set ToolbarType to ToolbarType.Custom when customizing ButtonStyle

public virtual ToolbarButtonStyle ButtonStyle {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonTitleMode Property

Determines how button titles are displayed

public ButtonTitleMode ButtonTitleMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ButtonType Property

Determines how buttons are displayed. Image is the default type.

public ButtonType ButtonType {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ConvertHtmlSymbolsToHtmlCodes Property

If true, strips out all the base

public bool ConvertHtmlSymbolsToHtmlCodes {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.DesignModeCss Property

The URL of the style sheet used in Design mode.

public string DesignModeCss {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.DownlevelColumns Property

The columns of the textarea if DownlevelMode is set to TextArea

public int DownlevelColumns {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.DownlevelMessage Property

The message displayed if DownlevelMode is set to Message.

public string DownlevelMessage {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.DownlevelMode Property

Determines what is displayed when a non-UpLevel browser tries to use the editor.

public DownlevelMode DownlevelMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.DownlevelRows Property

The rows of the textarea if DownlevelMode is set to TextArea

public int DownlevelRows {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.EditorBorderColorDark Property

The dark color of the border of the Editor window.

public System.Drawing.Color EditorBorderColorDark {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.EditorBorderColorLight Property

The light color of the border of the Editor window.

public System.Drawing.Color EditorBorderColorLight {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.EnableCurlyQuotes Property

Will insert curly quotes (using HTML codes “ and ”) in place of normal quotes. Default true.

public bool EnableCurlyQuotes {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.EnableSsl Property

If true, sets IFRAME source so that SSL will work

public bool EnableSsl {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontBackColorsMenuList Property

A list of colors for the font back colors drop down.

public System.Drawing.Color[] FontBackColorsMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontBackColorsMenuNames Property

A list of color names for the font back colors drop down.

public string[] FontBackColorsMenuNames {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontBackColorsMenuTitle Property

The title for the font back colors drop down.

public string FontBackColorsMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontFacesMenuList Property

A list of fonts for the font drop down.

public string[] FontFacesMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontFacesMenuTitle Property

The title for the font drop down.

public string FontFacesMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontForeColorsMenuList Property

A list of colors for the font fore colors drop down.

public System.Drawing.Color[] FontForeColorsMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontForeColorsMenuNames Property

A list of color names for the font fore colors drop down.

public string[] FontForeColorsMenuNames {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontForeColorsMenuTitle Property

The title for the font fore colors drop down.

public string FontForeColorsMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontSizesMenuList Property

A list of fonts sizes the font sizes drop down.

public string[] FontSizesMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.FontSizesMenuTitle Property

The title for the font sizes drop down.

public string FontSizesMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.GutterBackColor Property

The back color of the gutter of the tab area.

public System.Drawing.Color GutterBackColor {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.GutterBorderColorDark Property

The dark color of the border of the Editor window.

public System.Drawing.Color GutterBorderColorDark {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.GutterBorderColorLight Property

The light color of the border of the Editor window.

public System.Drawing.Color GutterBorderColorLight {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.Height Property

The height of the editor including toolbars.

public System.Web.UI.WebControls.Unit Height {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HelperFilesParameters Property

Parameters included with all helper scripts

public string HelperFilesParameters {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HelperFilesPath Property

The path to helper files. Default is blank which will look in the current directory. Automatically affixes a "/" if it's not included.

public string HelperFilesPath {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HtmlEncodedText Property

Applies Server.HtmlEncode to Text. Please note that Server.HtmlEncode does not recognize all HTML characters.

public string HtmlEncodedText {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HtmlMode Property

Determines what type of interface is used for HtmlMode

public HtmlMode HtmlMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HtmlModeCss Property

The URL of the style sheet used in HTML mode.

public string HtmlModeCss {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HtmlModeDefaultsToMonoSpaceFont Property

The URL of the style sheet used in HTML mode.

public bool HtmlModeDefaultsToMonoSpaceFont {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.HtmlStrippedText Property

Returns the Text property stripped of HTML, using Regex <(.|\n)+?>

public string HtmlStrippedText {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ImageGalleryPath Property

The path to for the InsertImageFromGallery Button. Defaults to "images". Use forward slashes "/" and do not all leading or trailing slashes.

public string ImageGalleryPath {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.InsertHtmlMenuList Property

A list of HTML for the insert HTML drop down.

public string[] InsertHtmlMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.InsertHtmlMenuNames Property

A list of names for items in the insert HTML drop down.

public string[] InsertHtmlMenuNames {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.InsertHtmlMenuTitle Property

The title for the insert HTML drop down.

public string InsertHtmlMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.IsBasicEditorCapable Property

Boolean value for the client's browser supports the Basic Editor

public bool IsBasicEditorCapable {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.IsMshtmlEditorCapable Property

Boolean value for if the client supports FreeTextBox.

public bool IsMshtmlEditorCapable {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ParagraphMenuList Property

A list of HTML values for the for the paragraph formatting drop down.

public string[] ParagraphMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ParagraphMenuNames Property

A list of paragraph names for the paragraph formatting drop down.

public string[] ParagraphMenuNames {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ParagraphMenuTitle Property

The title for the paragraph formatting drop down.

public string ParagraphMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.PasteMode Property

If true, does not allow pasting of text into FreeTextArea.

public PasteMode PasteMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.RawText Property

Outputs what is stored in the hidden HMTL field before any post processing

public string RawText {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ReadOnly Property

If true, HTML is not editable.

public bool ReadOnly {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.RemoveScriptNameFromBookmarks Property

Removes the scriptname from bookmarks

public bool RemoveScriptNameFromBookmarks {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.RemoveServerNameFromUrls Property

If true, strips out the local server name from all A and IMG tags

public bool RemoveServerNameFromUrls {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ScrollbarMode Property

Determines whether Styles are applied to the scrollbar

public ScrollbarMode ScrollbarMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ScrollbarStyle Property

Sets the style for the scrollbar

public virtual ScrollbarStyle ScrollbarStyle {get;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ShowStatusArea Property

Boolean value for whether the status area is shown when HtmlMode.Tabs is set.

public bool ShowStatusArea {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.StartMode Property

The rows of the textarea if DownlevelMode is set to TextArea

public EditorMode StartMode {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.StyleMenuList Property

A list of styles for the style drop down.

public string[] StyleMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.StyleMenuNames Property

A list of style names for the style drop down.

public string[] StyleMenuNames {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.StyleMenuTitle Property

The title for the styles drop down.

public string StyleMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.SymbolsMenuList Property

A list of HTML values for the symbols drop down.

public string[] SymbolsMenuList {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.SymbolsMenuTitle Property

The title for the symbols drop down.

public string SymbolsMenuTitle {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.Text Property

Contains the HTML for the editor.

public string Text {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ToolbarBackColor Property

The back color of each toolbar.

public System.Drawing.Color ToolbarBackColor {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ToolbarBackGroundImage Property

Uses the file toolbar.background file from the current image directory.

public bool ToolbarBackGroundImage {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ToolbarLayout Property

A string of buttons used to create the toolbar. Use commas (,) to separate items. A semicolon (;) will insert a separator and a pipe (|) will start a new Toolbar. Possible values are ParagraphMenu, FontFacesMenu, FontSizesMenu, FontForeColorsMenu, FontForeColorPicker, FontBackColorsMenu, FontBackColorPicker, Bold, Italic, Underline, Strikethrough, Superscript, Subscript;InsertImageFromGallery, CreateLink, Unlink, RemoveFormat, JustifyLeft, JustifyRight, JustifyCenter, JustifyFull;BulletedList, NumberedList, Indent, Outdent, Cut, Copy, Paste, Delete;Undo, Redo, Print, Save, ieSpellCheck, StyleMenu, SymbolsMenu, InsertHtmlMenu, InsertRule, InsertDate, InsertTime, WordCount

public string ToolbarLayout {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ToolbarType Property

Sets the style for how the toolbar is draw.

public ToolbarType ToolbarType {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.Width Property

The width of the editor.

public System.Web.UI.WebControls.Unit Width {get; set;}

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox Methods

The methods of the FreeTextBox class are listed below. For a complete list of FreeTextBox class members, see the FreeTextBox Members topic.

Public Instance Methods

DataBind (inherited from Control) |
Dispose (inherited from Control) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindControl (inherited from Control) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HasControls (inherited from Control) |
LoadPostData |
ProcessToolbarButton |
RaisePostBackEvent |
RaisePostDataChangedEvent |
RenderControl (inherited from Control) |
ResolveUrl (inherited from Control) |
SetRenderMethodDelegate (inherited from Control) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

AddParsedSubObject (inherited from Control) |
BuildProfileTree (inherited from Control) |
ClearChildViewState (inherited from Control) |
CreateChildControls |
CreateControlCollection (inherited from Control) |
EnsureChildControls (inherited from Control) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
FindControl (inherited from Control) |
IsLiteralContent (inherited from Control) |
LoadViewState |
MapPathSecure (inherited from Control) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBubbleEvent (inherited from Control) |
OnDataBinding (inherited from Control) |
OnInit |
OnLoad |
OnPreRender |
OnSaveClick | Event for Save button
OnUnload (inherited from Control) |
RaiseBubbleEvent (inherited from Control) |
RegisterClientScript |
Render (inherited from Control) |
RenderChildren (inherited from Control) |
SaveViewState |
TrackViewState (inherited from Control) |

Protected Internal Instance Methods

AddedControl (inherited from Control)
RemovedControl (inherited from Control)

Explicit Interface Implementations

IParserAccessor.AddParsedSubObject (inherited from Control)

See Also

FreeTextBox Class | FreeTextBoxControls Namespace


FreeTextBox.CreateChildControls Method

protected override void CreateChildControls();

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.LoadPostData Method

public bool LoadPostData(
string postDataKey,
NameValueCollection values
);

Implements

IPostBackDataHandler.LoadPostData

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.LoadViewState Method

protected override void LoadViewState(
object savedState
);

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.OnInit Method

protected override void OnInit(
EventArgs e
);

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.OnLoad Method

protected override void OnLoad(
EventArgs e
);

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.OnPreRender Method

protected override void OnPreRender(
EventArgs e
);

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.OnSaveClick Method

Event for Save button

protected virtual void OnSaveClick(
EventArgs e
);

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.ProcessToolbarButton Method

public virtual void ProcessToolbarButton(
ToolbarButton myButton
);

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.RaisePostBackEvent Method

public virtual void RaisePostBackEvent(
string eventArgument
);

Implements

IPostBackEventHandler.RaisePostBackEvent

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.RaisePostDataChangedEvent Method

public void RaisePostDataChangedEvent();

Implements

IPostBackDataHandler.RaisePostDataChangedEvent

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.RegisterClientScript Method

protected virtual void RegisterClientScript();

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox.SaveViewState Method

protected override object SaveViewState();

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


FreeTextBox Events

The events of the FreeTextBox class are listed below. For a complete list of FreeTextBox class members, see the FreeTextBox Members topic.

Public Instance Events

DataBinding (inherited from Control) |
Disposed (inherited from Control) |
Init (inherited from Control) |
Load (inherited from Control) |
PreRender (inherited from Control) |
SaveClick | The event fired when a Save button is pressed.
Unload (inherited from Control) |

See Also

FreeTextBox Class | FreeTextBoxControls Namespace


FreeTextBox.SaveClick Event

The event fired when a Save button is pressed.

public event EventHandler SaveClick;

See Also

FreeTextBox Class | FreeTextBox Members | FreeTextBoxControls Namespace


HtmlMode Enumeration

Determines what type of interface is displayed for switching between HtmlMode and DesignMode

public enum HtmlMode

Members

Member Name | Description
Tabs | Default. ASP.NET Web Matrix style tabs
Checkbox | An HTML checkbox is used for switching modes

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


PasteMode Enumeration

Determines what happens when a user pastes into the control

public enum PasteMode

Members

Member Name | Description
Default |
NoScript |
NoHtml |
Disabled |

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


ScrollbarMode Enumeration

Determines the style of the scroll bar.

public enum ScrollbarMode

Members

Member Name | Description
None | No styles are applied. The default scroll bar is used.
Style | Uses styles from the ScrollbarStyle object which defaults to a Visual Studio.NET style flat scrollbar.

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


ScrollbarStyle Class

Contains all the style parameters for ToolbarButtons

For a list of all members of this type, see ScrollbarStyle Members.

System.Object
MarshalByRefObject
Component
Style
ScrollbarStyle

public class ScrollbarStyle : Style

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle Members

Public Instance Constructors

ScrollbarStyle Overloaded. Initialize a new instance of the ScrollbarStyle class.

Public Instance Properties

ArrowColor | The color of the arrow elements of a scroll arrow.
BackColor (inherited from Style) |
BaseColor | The color of the main elements of a scroll bar, which include the scroll box, track, and scroll arrows
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
Container (inherited from Component) |
CssClass (inherited from Style) |
DarkShadowColor | The color of the gutter of a scroll bar.
FaceColor | The color of the scroll box and scroll arrows of a scroll bar.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
HighlightColor | The color of the top and left edges of the scroll box and scroll arrows of a scroll bar.
ShadowColor | The color of the bottom and right edges of the scroll box and scroll arrows of a scroll bar.
Site (inherited from Component) |
ThreeDLightColor | The color of the top and left edges of the scroll box and scroll arrows of a scroll bar.
TrackColor | The color of the track.
Width (inherited from Style) |

Public Instance Methods

AddAttributesToRender (inherited from Style) |
AddAttributesToRender (inherited from Style) |
CopyFrom (inherited from Style) |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) |
Reset (inherited from Style) |
ToString (inherited from Style) |

Public Instance Events

Disposed (inherited from Component)

Protected Instance Properties

DesignMode (inherited from Component)
Events (inherited from Component)
IsTrackingViewState (inherited from Style)

Protected Instance Methods

Dispose (inherited from Component) |
Finalize (inherited from Component) |
GetService (inherited from Component) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Properties

IsEmpty (inherited from Style)
ViewState (inherited from Style)

Protected Internal Instance Methods

LoadViewState (inherited from Style)
SaveViewState (inherited from Style)
SetBit (inherited from Style)
TrackViewState (inherited from Style)

Explicit Interface Implementations

IStateManager.LoadViewState (inherited from Style)
IStateManager.SaveViewState (inherited from Style)
IStateManager.TrackViewState (inherited from Style)

See Also

ScrollbarStyle Class | FreeTextBoxControls Namespace


ScrollbarStyle Constructor

Initializes a new instance of the ScrollbarStyle class.

Overload List

Initializes a new instance of the ScrollbarStyle class.

public ScrollbarStyle();

public ScrollbarStyle(Color,Color,Color,Color,Color,Color,Color,Color);

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle Constructor ()

Initializes a new instance of the ScrollbarStyle class.

public ScrollbarStyle();

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace | ScrollbarStyle Constructor Overload List


ScrollbarStyle Constructor (Color, Color, Color, Color, Color, Color, Color, Color)

public ScrollbarStyle(
Color threeDLightColor,
Color arrowColor,
Color baseColor,
Color darkShadowColor,
Color faceColor,
Color highlightColor,
Color shadowColor,
Color trackColor
);

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace | ScrollbarStyle Constructor Overload List


ScrollbarStyle Properties

The properties of the ScrollbarStyle class are listed below. For a complete list of ScrollbarStyle class members, see the ScrollbarStyle Members topic.

Public Instance Properties

ArrowColor | The color of the arrow elements of a scroll arrow.
BackColor (inherited from Style) |
BaseColor | The color of the main elements of a scroll bar, which include the scroll box, track, and scroll arrows
BorderColor (inherited from Style) |
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
Container (inherited from Component) |
CssClass (inherited from Style) |
DarkShadowColor | The color of the gutter of a scroll bar.
FaceColor | The color of the scroll box and scroll arrows of a scroll bar.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
HighlightColor | The color of the top and left edges of the scroll box and scroll arrows of a scroll bar.
ShadowColor | The color of the bottom and right edges of the scroll box and scroll arrows of a scroll bar.
Site (inherited from Component) |
ThreeDLightColor | The color of the top and left edges of the scroll box and scroll arrows of a scroll bar.
TrackColor | The color of the track.
Width (inherited from Style) |

Protected Instance Properties

DesignMode (inherited from Component)
Events (inherited from Component)
IsTrackingViewState (inherited from Style)

Protected Internal Instance Properties

IsEmpty (inherited from Style)
ViewState (inherited from Style)

See Also

ScrollbarStyle Class | FreeTextBoxControls Namespace


ScrollbarStyle.ArrowColor Property

The color of the arrow elements of a scroll arrow.

public System.Drawing.Color ArrowColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.BaseColor Property

The color of the main elements of a scroll bar, which include the scroll box, track, and scroll arrows

public System.Drawing.Color BaseColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.DarkShadowColor Property

The color of the gutter of a scroll bar.

public System.Drawing.Color DarkShadowColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.FaceColor Property

The color of the scroll box and scroll arrows of a scroll bar.

public System.Drawing.Color FaceColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.HighlightColor Property

The color of the top and left edges of the scroll box and scroll arrows of a scroll bar.

public System.Drawing.Color HighlightColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.ShadowColor Property

The color of the bottom and right edges of the scroll box and scroll arrows of a scroll bar.

public System.Drawing.Color ShadowColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.ThreeDLightColor Property

The color of the top and left edges of the scroll box and scroll arrows of a scroll bar.

public System.Drawing.Color ThreeDLightColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


ScrollbarStyle.TrackColor Property

The color of the track.

public System.Drawing.Color TrackColor {get; set;}

See Also

ScrollbarStyle Class | ScrollbarStyle Members | FreeTextBoxControls Namespace


Toolbar Class

A Toolbar for FreeTextBox

For a list of all members of this type, see Toolbar Members.

System.Object
Toolbar

public class Toolbar

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

Toolbar Members | FreeTextBoxControls Namespace


Toolbar Members

Public Instance Constructors

Toolbar Overloaded. Initialize a new instance of the Toolbar class.

Public Instance Fields

Items The Items (ToolbarButton, ToolbarDropDownList, ToolbarSeparator) in the toolbar

Public Instance Properties

Moveable | Not Implimented
Name | The name of the Toolbar
Visible | Whether the toolbar will be rendered visible

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Toolbar Class | FreeTextBoxControls Namespace


Toolbar Constructor

Initializes a new instance of the Toolbar class.

Overload List

Initializes a new instance of the Toolbar class.

public Toolbar();

public Toolbar(string);

public Toolbar(string,bool);

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace


Toolbar Constructor ()

Initializes a new instance of the Toolbar class.

public Toolbar();

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace | Toolbar Constructor Overload List


Toolbar Constructor (String)

public Toolbar(
string name
);

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace | Toolbar Constructor Overload List


Toolbar Constructor (String, Boolean)

public Toolbar(
string name,
bool moveable
);

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace | Toolbar Constructor Overload List


Toolbar Fields

The fields of the Toolbar class are listed below. For a complete list of Toolbar class members, see the Toolbar Members topic.

Public Instance Fields

Items The Items (ToolbarButton, ToolbarDropDownList, ToolbarSeparator) in the toolbar

See Also

Toolbar Class | FreeTextBoxControls Namespace


Toolbar.Items Field

The Items (ToolbarButton, ToolbarDropDownList, ToolbarSeparator) in the toolbar

public ToolbarItemsList Items;

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace


Toolbar Properties

The properties of the Toolbar class are listed below. For a complete list of Toolbar class members, see the Toolbar Members topic.

Public Instance Properties

Moveable | Not Implimented
Name | The name of the Toolbar
Visible | Whether the toolbar will be rendered visible

See Also

Toolbar Class | FreeTextBoxControls Namespace


Toolbar.Moveable Property

Not Implimented

public bool Moveable {get; set;}

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace


Toolbar.Name Property

The name of the Toolbar

public string Name {get; set;}

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace


Toolbar.Visible Property

Whether the toolbar will be rendered visible

public bool Visible {get; set;}

See Also

Toolbar Class | Toolbar Members | FreeTextBoxControls Namespace


ToolbarButton Class

A button used in an Toolbar

For a list of all members of this type, see ToolbarButton Members.

System.Object
ToolbarItem
ToolbarButton

public class ToolbarButton : ToolbarItem

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarButton Members | FreeTextBoxControls Namespace


ToolbarButton Members

Public Instance Constructors

ToolbarButton Overloaded. Initialize a new instance of the ToolbarButton class.

Public Instance Fields

ButtonTitleMode Determines how the title of the button will be displayed

Public Instance Properties

CommandIdentifier (inherited from ToolbarItem) | The MSHTML specific command identifier used for dynamic updating through the queryCommandState method
Function (inherited from ToolbarItem) | The javascript function fired when the item's action is triggered
Height (inherited from ToolbarItem) | Button Height
Href | Used if a button does not execute a function
Name (inherited from ToolbarItem) | The Name of the ToolbarItem
ScriptBlock (inherited from ToolbarItem) | The JavaScript code for the function
ScriptBlockBasic (inherited from ToolbarItem) | The JavaScript used for the simple editor for Netscape and IE4
Target | The target for Href property
Title (inherited from ToolbarItem) | The Title of the ToolbarItem
TitleVisible | Determines whether a button's Title is shown
Visible (inherited from ToolbarItem) | Whether the item is visible
Width (inherited from ToolbarItem) | Button Width

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarButton Class | FreeTextBoxControls Namespace


ToolbarButton Constructor

Initializes a new instance of the ToolbarButton class.

Overload List

Initializes a new instance of the ToolbarButton class.

public ToolbarButton();

public ToolbarButton(string,string,string);

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace


ToolbarButton Constructor ()

Initializes a new instance of the ToolbarButton class.

public ToolbarButton();

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace | ToolbarButton Constructor Overload List


ToolbarButton Constructor (String, String, String)

public ToolbarButton(
string title,
string name,
string function
);

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace | ToolbarButton Constructor Overload List


ToolbarButton Fields

The fields of the ToolbarButton class are listed below. For a complete list of ToolbarButton class members, see the ToolbarButton Members topic.

Public Instance Fields

ButtonTitleMode Determines how the title of the button will be displayed

See Also

ToolbarButton Class | FreeTextBoxControls Namespace


ToolbarButton.ButtonTitleMode Field

Determines how the title of the button will be displayed

public ButtonTitleMode ButtonTitleMode;

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace


ToolbarButton Properties

The properties of the ToolbarButton class are listed below. For a complete list of ToolbarButton class members, see the ToolbarButton Members topic.

Public Instance Properties

CommandIdentifier (inherited from ToolbarItem) | The MSHTML specific command identifier used for dynamic updating through the queryCommandState method
Function (inherited from ToolbarItem) | The javascript function fired when the item's action is triggered
Height (inherited from ToolbarItem) | Button Height
Href | Used if a button does not execute a function
Name (inherited from ToolbarItem) | The Name of the ToolbarItem
ScriptBlock (inherited from ToolbarItem) | The JavaScript code for the function
ScriptBlockBasic (inherited from ToolbarItem) | The JavaScript used for the simple editor for Netscape and IE4
Target | The target for Href property
Title (inherited from ToolbarItem) | The Title of the ToolbarItem
TitleVisible | Determines whether a button's Title is shown
Visible (inherited from ToolbarItem) | Whether the item is visible
Width (inherited from ToolbarItem) | Button Width

See Also

ToolbarButton Class | FreeTextBoxControls Namespace


ToolbarButton.Href Property

Used if a button does not execute a function

public string Href {get; set;}

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace


ToolbarButton.Target Property

The target for Href property

public string Target {get; set;}

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace


ToolbarButton.TitleVisible Property

Determines whether a button's Title is shown

public bool TitleVisible {get; set;}

See Also

ToolbarButton Class | ToolbarButton Members | FreeTextBoxControls Namespace


ToolbarButtonStyle Class

Contains all the style parameters for ToolbarButtons

For a list of all members of this type, see ToolbarButtonStyle Members.

System.Object
MarshalByRefObject
Component
Style
ToolbarButtonStyle

public class ToolbarButtonStyle : Style

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle Members

Public Instance Constructors

ToolbarButtonStyle Overloaded. Initialize a new instance of the ToolbarButtonStyle class.

Public Instance Properties

BackColor (inherited from Style) |
BorderColor | Sets BorderColorLight and BorderColorDark.
BorderColorDark | The default dark (right and bottom) border color of buttons.
BorderColorLight | The default light (top and left) border color of buttons.
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
Container (inherited from Component) |
CssClass (inherited from Style) |
DownBackColor | The default onMouseDown back color of buttons.
DownBackgroundImage | The background image onMouseDown.
DownBorderColorDark | The default onMouseDown dark (right and bottom) border color of buttons onMouseDown.
DownBorderColorLight | The default onMouseDown light (top and left) border color of buttons onMouseDown.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
OverBackColor | The default onMouseOver back color of buttons.
OverBackgroundImage | The background image onMouseDown.
OverBorderColorDark | The default onMouseOver dark (right and bottom) border color of buttons.
OverBorderColorLight | The default onMouseOver light (top and left) border color of buttons.
Site (inherited from Component) |
Width (inherited from Style) |

Public Instance Methods

AddAttributesToRender (inherited from Style) |
AddAttributesToRender (inherited from Style) |
CopyFrom (inherited from Style) |
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MergeWith (inherited from Style) |
Reset (inherited from Style) |
ToString (inherited from Style) |

Public Instance Events

Disposed (inherited from Component)

Protected Instance Properties

DesignMode (inherited from Component)
Events (inherited from Component)
IsTrackingViewState (inherited from Style)

Protected Instance Methods

Dispose (inherited from Component) |
Finalize (inherited from Component) |
GetService (inherited from Component) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Properties

IsEmpty (inherited from Style)
ViewState (inherited from Style)

Protected Internal Instance Methods

LoadViewState (inherited from Style)
SaveViewState (inherited from Style)
SetBit (inherited from Style)
TrackViewState (inherited from Style)

Explicit Interface Implementations

IStateManager.LoadViewState (inherited from Style)
IStateManager.SaveViewState (inherited from Style)
IStateManager.TrackViewState (inherited from Style)

See Also

ToolbarButtonStyle Class | FreeTextBoxControls Namespace


ToolbarButtonStyle Constructor

Empty constructor

Overload List

Empty constructor

public ToolbarButtonStyle();

Constructor for colors only

public ToolbarButtonStyle(Color,Color,Color,Color,Color,Color,Color,Color);

Constructor with colors and images

public ToolbarButtonStyle(Color,Color,string,Color,Color,string,Color,Color);

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle Constructor ()

Empty constructor

public ToolbarButtonStyle();

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace | ToolbarButtonStyle Constructor Overload List


ToolbarButtonStyle Constructor (Color, Color, Color, Color, Color, Color, Color, Color)

Constructor for colors only

public ToolbarButtonStyle(
Color borderColorLight,
Color borderColorDark,
Color overBackColor,
Color overBorderColorLight,
Color overBorderColorDark,
Color downBackColor,
Color downBorderColorLight,
Color downBorderColorDark
);

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace | ToolbarButtonStyle Constructor Overload List


ToolbarButtonStyle Constructor (Color, Color, String, Color, Color, String, Color, Color)

Constructor with colors and images

public ToolbarButtonStyle(
Color borderColorLight,
Color borderColorDark,
string overBackgroundImage,
Color overBorderColorLight,
Color overBorderColorDark,
string downBackgroundImage,
Color downBorderColorLight,
Color downBorderColorDark
);

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace | ToolbarButtonStyle Constructor Overload List


ToolbarButtonStyle Properties

The properties of the ToolbarButtonStyle class are listed below. For a complete list of ToolbarButtonStyle class members, see the ToolbarButtonStyle Members topic.

Public Instance Properties

BackColor (inherited from Style) |
BorderColor | Sets BorderColorLight and BorderColorDark.
BorderColorDark | The default dark (right and bottom) border color of buttons.
BorderColorLight | The default light (top and left) border color of buttons.
BorderStyle (inherited from Style) |
BorderWidth (inherited from Style) |
Container (inherited from Component) |
CssClass (inherited from Style) |
DownBackColor | The default onMouseDown back color of buttons.
DownBackgroundImage | The background image onMouseDown.
DownBorderColorDark | The default onMouseDown dark (right and bottom) border color of buttons onMouseDown.
DownBorderColorLight | The default onMouseDown light (top and left) border color of buttons onMouseDown.
Font (inherited from Style) |
ForeColor (inherited from Style) |
Height (inherited from Style) |
OverBackColor | The default onMouseOver back color of buttons.
OverBackgroundImage | The background image onMouseDown.
OverBorderColorDark | The default onMouseOver dark (right and bottom) border color of buttons.
OverBorderColorLight | The default onMouseOver light (top and left) border color of buttons.
Site (inherited from Component) |
Width (inherited from Style) |

Protected Instance Properties

DesignMode (inherited from Component)
Events (inherited from Component)
IsTrackingViewState (inherited from Style)

Protected Internal Instance Properties

IsEmpty (inherited from Style)
ViewState (inherited from Style)

See Also

ToolbarButtonStyle Class | FreeTextBoxControls Namespace


ToolbarButtonStyle.BorderColor Property

Sets BorderColorLight and BorderColorDark.

new public System.Drawing.Color BorderColor {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.BorderColorDark Property

The default dark (right and bottom) border color of buttons.

public System.Drawing.Color BorderColorDark {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.BorderColorLight Property

The default light (top and left) border color of buttons.

public System.Drawing.Color BorderColorLight {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.DownBackColor Property

The default onMouseDown back color of buttons.

public System.Drawing.Color DownBackColor {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.DownBackgroundImage Property

The background image onMouseDown.

public string DownBackgroundImage {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.DownBorderColorDark Property

The default onMouseDown dark (right and bottom) border color of buttons onMouseDown.

public System.Drawing.Color DownBorderColorDark {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.DownBorderColorLight Property

The default onMouseDown light (top and left) border color of buttons onMouseDown.

public System.Drawing.Color DownBorderColorLight {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.OverBackColor Property

The default onMouseOver back color of buttons.

public System.Drawing.Color OverBackColor {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.OverBackgroundImage Property

The background image onMouseDown.

public string OverBackgroundImage {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.OverBorderColorDark Property

The default onMouseOver dark (right and bottom) border color of buttons.

public System.Drawing.Color OverBorderColorDark {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarButtonStyle.OverBorderColorLight Property

The default onMouseOver light (top and left) border color of buttons.

public System.Drawing.Color OverBorderColorLight {get; set;}

See Also

ToolbarButtonStyle Class | ToolbarButtonStyle Members | FreeTextBoxControls Namespace


ToolbarDropDownList Class

A DropDownList for a Toolbar

For a list of all members of this type, see ToolbarDropDownList Members.

System.Object
ToolbarItem
ToolbarDropDownList

public class ToolbarDropDownList : ToolbarItem

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarDropDownList Members | FreeTextBoxControls Namespace


ToolbarDropDownList Members

Public Instance Constructors

ToolbarDropDownList Overloaded. Initialize a new instance of the ToolbarDropDownList class.

Public Instance Fields

Items Collection of ToolbarListItems

Public Instance Properties

CommandIdentifier (inherited from ToolbarItem) | The MSHTML specific command identifier used for dynamic updating through the queryCommandState method
Function (inherited from ToolbarItem) | The javascript function fired when the item's action is triggered
Height (inherited from ToolbarItem) | Button Height
Name (inherited from ToolbarItem) | The Name of the ToolbarItem
ScriptBlock (inherited from ToolbarItem) | The JavaScript code for the function
ScriptBlockBasic (inherited from ToolbarItem) | The JavaScript used for the simple editor for Netscape and IE4
Title (inherited from ToolbarItem) | The Title of the ToolbarItem
Visible (inherited from ToolbarItem) | Whether the item is visible
Width (inherited from ToolbarItem) | Button Width

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarDropDownList Class | FreeTextBoxControls Namespace


ToolbarDropDownList Constructor

Initializes a new instance of the ToolbarDropDownList class.

Overload List

Initializes a new instance of the ToolbarDropDownList class.

public ToolbarDropDownList();

public ToolbarDropDownList(string,string,string);

See Also

ToolbarDropDownList Class | ToolbarDropDownList Members | FreeTextBoxControls Namespace


ToolbarDropDownList Constructor ()

Initializes a new instance of the ToolbarDropDownList class.

public ToolbarDropDownList();

See Also

ToolbarDropDownList Class | ToolbarDropDownList Members | FreeTextBoxControls Namespace | ToolbarDropDownList Constructor Overload List


ToolbarDropDownList Constructor (String, String, String)

public ToolbarDropDownList(
string title,
string name,
string function
);

See Also

ToolbarDropDownList Class | ToolbarDropDownList Members | FreeTextBoxControls Namespace | ToolbarDropDownList Constructor Overload List


ToolbarDropDownList Fields

The fields of the ToolbarDropDownList class are listed below. For a complete list of ToolbarDropDownList class members, see the ToolbarDropDownList Members topic.

Public Instance Fields

Items Collection of ToolbarListItems

See Also

ToolbarDropDownList Class | FreeTextBoxControls Namespace


ToolbarDropDownList.Items Field

Collection of ToolbarListItems

public ToolbarDropDownListItems Items;

See Also

ToolbarDropDownList Class | ToolbarDropDownList Members | FreeTextBoxControls Namespace


ToolbarGenerator Class

Builds Toolbars and ToolbarItems from strings

For a list of all members of this type, see ToolbarGenerator Members.

System.Object
ToolbarGenerator

public class ToolbarGenerator

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator Members

Public Static Fields

AlternateConfigString
DefaultConfigString
EnableAllConfigString
MinimalConfigString

Public Static Properties

Alternate | Returns a Toolbars with an alternate configuration
Default | Returns a Toolbars with the default configuration
EnableAll | Returns a Toolbars with the all buttons and dropdowns enabled
Minimal | Returns a Toolbars with only bold, italic, and underline

Public Static Methods

ToolbarItemFromString | Returns a ToolbarItem from it's string representation. If an invalid string is given, a ToolbarSeparator is returned.
ToolbarsFromString | Generates Toolbars from ToolbarLayout string

Public Instance Constructors

ToolbarGenerator Constructor Initializes a new instance of the ToolbarGenerator class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarGenerator Class | FreeTextBoxControls Namespace


ToolbarGenerator Constructor

Initializes a new instance of the ToolbarGenerator class.

public ToolbarGenerator();

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator Fields

The fields of the ToolbarGenerator class are listed below. For a complete list of ToolbarGenerator class members, see the ToolbarGenerator Members topic.

Public Static Fields

AlternateConfigString
DefaultConfigString
EnableAllConfigString
MinimalConfigString

See Also

ToolbarGenerator Class | FreeTextBoxControls Namespace


ToolbarGenerator.AlternateConfigString Field

public static string AlternateConfigString;

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.DefaultConfigString Field

public static string DefaultConfigString;

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.EnableAllConfigString Field

public static string EnableAllConfigString;

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.MinimalConfigString Field

public static string MinimalConfigString;

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator Properties

The properties of the ToolbarGenerator class are listed below. For a complete list of ToolbarGenerator class members, see the ToolbarGenerator Members topic.

Public Static Properties

Alternate | Returns a Toolbars with an alternate configuration
Default | Returns a Toolbars with the default configuration
EnableAll | Returns a Toolbars with the all buttons and dropdowns enabled
Minimal | Returns a Toolbars with only bold, italic, and underline

See Also

ToolbarGenerator Class | FreeTextBoxControls Namespace


ToolbarGenerator.Alternate Property

Returns a Toolbars with an alternate configuration

public static Common.ToolbarList Alternate {get;}

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.Default Property

Returns a Toolbars with the default configuration

public static Common.ToolbarList Default {get;}

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.EnableAll Property

Returns a Toolbars with the all buttons and dropdowns enabled

public static Common.ToolbarList EnableAll {get;}

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.Minimal Property

Returns a Toolbars with only bold, italic, and underline

public static Common.ToolbarList Minimal {get;}

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator Methods

The methods of the ToolbarGenerator class are listed below. For a complete list of ToolbarGenerator class members, see the ToolbarGenerator Members topic.

Public Static Methods

ToolbarItemFromString | Returns a ToolbarItem from it's string representation. If an invalid string is given, a ToolbarSeparator is returned.
ToolbarsFromString | Generates Toolbars from ToolbarLayout string

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarGenerator Class | FreeTextBoxControls Namespace


ToolbarGenerator.ToolbarItemFromString Method

Returns a ToolbarItem from it's string representation. If an invalid string is given, a ToolbarSeparator is returned.

public static ToolbarItem ToolbarItemFromString(
string StringName
);

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarGenerator.ToolbarsFromString Method

Generates Toolbars from ToolbarLayout string

public static ToolbarList ToolbarsFromString(
string toolbarLayout
);

See Also

ToolbarGenerator Class | ToolbarGenerator Members | FreeTextBoxControls Namespace


ToolbarItem Class

Abstract class for all toolbar items

For a list of all members of this type, see ToolbarItem Members.

System.Object
ToolbarItem

public abstract class ToolbarItem

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem Members

Public Instance Constructors

ToolbarItem Constructor Initializes a new instance of the ToolbarItem class.

Public Instance Properties

CommandIdentifier | The MSHTML specific command identifier used for dynamic updating through the queryCommandState method
Function | The javascript function fired when the item's action is triggered
Height | Button Height
Name | The Name of the ToolbarItem
ScriptBlock | The JavaScript code for the function
ScriptBlockBasic | The JavaScript used for the simple editor for Netscape and IE4
Title | The Title of the ToolbarItem
Visible | Whether the item is visible
Width | Button Width

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarItem Class | FreeTextBoxControls Namespace


ToolbarItem Constructor

Initializes a new instance of the ToolbarItem class.

public ToolbarItem();

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem Properties

The properties of the ToolbarItem class are listed below. For a complete list of ToolbarItem class members, see the ToolbarItem Members topic.

Public Instance Properties

CommandIdentifier | The MSHTML specific command identifier used for dynamic updating through the queryCommandState method
Function | The javascript function fired when the item's action is triggered
Height | Button Height
Name | The Name of the ToolbarItem
ScriptBlock | The JavaScript code for the function
ScriptBlockBasic | The JavaScript used for the simple editor for Netscape and IE4
Title | The Title of the ToolbarItem
Visible | Whether the item is visible
Width | Button Width

See Also

ToolbarItem Class | FreeTextBoxControls Namespace


ToolbarItem.CommandIdentifier Property

The MSHTML specific command identifier used for dynamic updating through the queryCommandState method

public string CommandIdentifier {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.Function Property

The javascript function fired when the item's action is triggered

public string Function {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.Height Property

Button Height

public System.Web.UI.WebControls.Unit Height {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.Name Property

The Name of the ToolbarItem

public string Name {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.ScriptBlock Property

The JavaScript code for the function

public string ScriptBlock {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.ScriptBlockBasic Property

The JavaScript used for the simple editor for Netscape and IE4

public string ScriptBlockBasic {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.Title Property

The Title of the ToolbarItem

public string Title {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.Visible Property

Whether the item is visible

public bool Visible {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItem.Width Property

Button Width

public System.Web.UI.WebControls.Unit Width {get; set;}

See Also

ToolbarItem Class | ToolbarItem Members | FreeTextBoxControls Namespace


ToolbarItems Class

Contains all the built-in ToolbarButtons and ToolbarDropDownLists

For a list of all members of this type, see ToolbarItems Members.

System.Object
ToolbarItems

public class ToolbarItems

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems Members

Public Static Properties

Bold | Returns a ToolbarButton with Bold JavaScript functions builtin
BulletedList | Returns a ToolbarButton with BulletedList JavaScript functions builtin
ChangeCase | Returns a ToolbarButton with ChangeCase JavaScript functions builtin
Copy | Returns a ToolbarButton with Copy JavaScript functions builtin
CreateLink | Returns a ToolbarButton with CreateLink JavaScript functions builtin
Cut | Returns a ToolbarButton with Cut JavaScript functions builtin
Delete | Returns a ToolbarButton with Delete JavaScript functions builtin
FontBackColorPicker | Returns a ToolbarButton with FontBackColorPicker JavaScript functions builtin
FontBackColorsMenu | Returns a ToolbarDropDownList with FontBackColorsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
FontFacesMenu | Returns a ToolbarDropDownList with FontFacesMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
FontForeColorPicker | Returns a ToolbarButton with FontForeColorPicker JavaScript functions builtin
FontForeColorsMenu | Returns a ToolbarDropDownList with FontForeColorsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
FontSizesMenu | Returns a ToolbarDropDownList with FontSizesMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
ieSpellCheck | Returns a ToolbarButton with ieSpellCheck JavaScript functions builtin
Indent | Returns a ToolbarButton with Indent JavaScript functions builtin
InsertDate | Returns a ToolbarButton with InsertDate JavaScript functions builtin
InsertHtmlMenu | Returns a ToolbarDropDownList with InsertHtmlMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
InsertImage | Returns a ToolbarButton with InsertImage JavaScript functions builtin
InsertImageFromGallery | Returns a ToolbarButton with InsertImageFromGallery JavaScript functions builtin
InsertRule | Returns a ToolbarButton with InsertRule JavaScript functions builtin
InsertTable | Returns a ToolbarButton with InsertTable JavaScript functions builtin
InsertTime | Returns a ToolbarButton with InsertTime JavaScript functions builtin
Italic | Returns a ToolbarButton with Italic JavaScript functions builtin
JustifyCenter | Returns a ToolbarButton with JustifyCenter JavaScript functions builtin
JustifyFull | Returns a ToolbarButton with JustifyFull JavaScript functions builtin
JustifyLeft | Returns a ToolbarButton with JustifyLeft JavaScript functions builtin
JustifyRight | Returns a ToolbarButton with JustifyRight JavaScript functions builtin
NumberedList | Returns a ToolbarButton with NumberedList JavaScript functions builtin
Outdent | Returns a ToolbarButton with Outdent JavaScript functions builtin
ParagraphMenu | Returns a ToolbarDropDownList with ParagraphMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
Paste | Returns a ToolbarButton with Paste JavaScript functions builtin
Print | Returns a ToolbarButton with Print JavaScript functions builtin
Redo | Returns a ToolbarButton with Redo JavaScript functions builtin
RemoveFormat | Returns a ToolbarButton with RemoveFormat JavaScript functions builtin
Save | Returns a ToolbarButton with Save JavaScript functions builtin
Separator | Returns a ToolbarSeparator
Strikethrough | Returns a ToolbarButton with Strikethrough JavaScript functions builtin
StyleMenu | Returns a ToolbarDropDownList with StyleMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
Subscript | Returns a ToolbarButton with Subscript JavaScript functions builtin
Superscript | Returns a ToolbarButton with Superscript JavaScript functions builtin
SymbolsMenu | Returns a ToolbarDropDownList with SymbolsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
Underline | Returns a ToolbarButton with Underline JavaScript functions builtin
Undo | Returns a ToolbarButton with Undo JavaScript functions builtin
Unlink | Returns a ToolbarButton with Unlink JavaScript functions builtin
WordClean | Returns a ToolbarButton with InsertImage JavaScript functions builtin
WordCount | Returns a ToolbarButton with WordCount JavaScript functions builtin

Public Instance Constructors

ToolbarItems Constructor Initializes a new instance of the ToolbarItems class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarItems Class | FreeTextBoxControls Namespace


ToolbarItems Constructor

Initializes a new instance of the ToolbarItems class.

public ToolbarItems();

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems Properties

The properties of the ToolbarItems class are listed below. For a complete list of ToolbarItems class members, see the ToolbarItems Members topic.

Public Static Properties

Bold | Returns a ToolbarButton with Bold JavaScript functions builtin
BulletedList | Returns a ToolbarButton with BulletedList JavaScript functions builtin
ChangeCase | Returns a ToolbarButton with ChangeCase JavaScript functions builtin
Copy | Returns a ToolbarButton with Copy JavaScript functions builtin
CreateLink | Returns a ToolbarButton with CreateLink JavaScript functions builtin
Cut | Returns a ToolbarButton with Cut JavaScript functions builtin
Delete | Returns a ToolbarButton with Delete JavaScript functions builtin
FontBackColorPicker | Returns a ToolbarButton with FontBackColorPicker JavaScript functions builtin
FontBackColorsMenu | Returns a ToolbarDropDownList with FontBackColorsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
FontFacesMenu | Returns a ToolbarDropDownList with FontFacesMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
FontForeColorPicker | Returns a ToolbarButton with FontForeColorPicker JavaScript functions builtin
FontForeColorsMenu | Returns a ToolbarDropDownList with FontForeColorsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
FontSizesMenu | Returns a ToolbarDropDownList with FontSizesMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
ieSpellCheck | Returns a ToolbarButton with ieSpellCheck JavaScript functions builtin
Indent | Returns a ToolbarButton with Indent JavaScript functions builtin
InsertDate | Returns a ToolbarButton with InsertDate JavaScript functions builtin
InsertHtmlMenu | Returns a ToolbarDropDownList with InsertHtmlMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
InsertImage | Returns a ToolbarButton with InsertImage JavaScript functions builtin
InsertImageFromGallery | Returns a ToolbarButton with InsertImageFromGallery JavaScript functions builtin
InsertRule | Returns a ToolbarButton with InsertRule JavaScript functions builtin
InsertTable | Returns a ToolbarButton with InsertTable JavaScript functions builtin
InsertTime | Returns a ToolbarButton with InsertTime JavaScript functions builtin
Italic | Returns a ToolbarButton with Italic JavaScript functions builtin
JustifyCenter | Returns a ToolbarButton with JustifyCenter JavaScript functions builtin
JustifyFull | Returns a ToolbarButton with JustifyFull JavaScript functions builtin
JustifyLeft | Returns a ToolbarButton with JustifyLeft JavaScript functions builtin
JustifyRight | Returns a ToolbarButton with JustifyRight JavaScript functions builtin
NumberedList | Returns a ToolbarButton with NumberedList JavaScript functions builtin
Outdent | Returns a ToolbarButton with Outdent JavaScript functions builtin
ParagraphMenu | Returns a ToolbarDropDownList with ParagraphMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
Paste | Returns a ToolbarButton with Paste JavaScript functions builtin
Print | Returns a ToolbarButton with Print JavaScript functions builtin
Redo | Returns a ToolbarButton with Redo JavaScript functions builtin
RemoveFormat | Returns a ToolbarButton with RemoveFormat JavaScript functions builtin
Save | Returns a ToolbarButton with Save JavaScript functions builtin
Separator | Returns a ToolbarSeparator
Strikethrough | Returns a ToolbarButton with Strikethrough JavaScript functions builtin
StyleMenu | Returns a ToolbarDropDownList with StyleMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
Subscript | Returns a ToolbarButton with Subscript JavaScript functions builtin
Superscript | Returns a ToolbarButton with Superscript JavaScript functions builtin
SymbolsMenu | Returns a ToolbarDropDownList with SymbolsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.
Underline | Returns a ToolbarButton with Underline JavaScript functions builtin
Undo | Returns a ToolbarButton with Undo JavaScript functions builtin
Unlink | Returns a ToolbarButton with Unlink JavaScript functions builtin
WordClean | Returns a ToolbarButton with InsertImage JavaScript functions builtin
WordCount | Returns a ToolbarButton with WordCount JavaScript functions builtin

See Also

ToolbarItems Class | FreeTextBoxControls Namespace


ToolbarItems.Bold Property

Returns a ToolbarButton with Bold JavaScript functions builtin

public static ToolbarButton Bold {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.BulletedList Property

Returns a ToolbarButton with BulletedList JavaScript functions builtin

public static ToolbarButton BulletedList {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.ChangeCase Property

Returns a ToolbarButton with ChangeCase JavaScript functions builtin

public static ToolbarButton ChangeCase {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Copy Property

Returns a ToolbarButton with Copy JavaScript functions builtin

public static ToolbarButton Copy {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.CreateLink Property

Returns a ToolbarButton with CreateLink JavaScript functions builtin

public static ToolbarButton CreateLink {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Cut Property

Returns a ToolbarButton with Cut JavaScript functions builtin

public static ToolbarButton Cut {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Delete Property

Returns a ToolbarButton with Delete JavaScript functions builtin

public static ToolbarButton Delete {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.FontBackColorPicker Property

Returns a ToolbarButton with FontBackColorPicker JavaScript functions builtin

public static ToolbarButton FontBackColorPicker {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.FontBackColorsMenu Property

Returns a ToolbarDropDownList with FontBackColorsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList FontBackColorsMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.FontFacesMenu Property

Returns a ToolbarDropDownList with FontFacesMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList FontFacesMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.FontForeColorPicker Property

Returns a ToolbarButton with FontForeColorPicker JavaScript functions builtin

public static ToolbarButton FontForeColorPicker {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.FontForeColorsMenu Property

Returns a ToolbarDropDownList with FontForeColorsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList FontForeColorsMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.FontSizesMenu Property

Returns a ToolbarDropDownList with FontSizesMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList FontSizesMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.ieSpellCheck Property

Returns a ToolbarButton with ieSpellCheck JavaScript functions builtin

public static ToolbarButton ieSpellCheck {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Indent Property

Returns a ToolbarButton with Indent JavaScript functions builtin

public static ToolbarButton Indent {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertDate Property

Returns a ToolbarButton with InsertDate JavaScript functions builtin

public static ToolbarButton InsertDate {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertHtmlMenu Property

Returns a ToolbarDropDownList with InsertHtmlMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList InsertHtmlMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertImage Property

Returns a ToolbarButton with InsertImage JavaScript functions builtin

public static ToolbarButton InsertImage {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertImageFromGallery Property

Returns a ToolbarButton with InsertImageFromGallery JavaScript functions builtin

public static ToolbarButton InsertImageFromGallery {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertRule Property

Returns a ToolbarButton with InsertRule JavaScript functions builtin

public static ToolbarButton InsertRule {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertTable Property

Returns a ToolbarButton with InsertTable JavaScript functions builtin

public static ToolbarButton InsertTable {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.InsertTime Property

Returns a ToolbarButton with InsertTime JavaScript functions builtin

public static ToolbarButton InsertTime {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Italic Property

Returns a ToolbarButton with Italic JavaScript functions builtin

public static ToolbarButton Italic {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.JustifyCenter Property

Returns a ToolbarButton with JustifyCenter JavaScript functions builtin

public static ToolbarButton JustifyCenter {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.JustifyFull Property

Returns a ToolbarButton with JustifyFull JavaScript functions builtin

public static ToolbarButton JustifyFull {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.JustifyLeft Property

Returns a ToolbarButton with JustifyLeft JavaScript functions builtin

public static ToolbarButton JustifyLeft {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.JustifyRight Property

Returns a ToolbarButton with JustifyRight JavaScript functions builtin

public static ToolbarButton JustifyRight {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.NumberedList Property

Returns a ToolbarButton with NumberedList JavaScript functions builtin

public static ToolbarButton NumberedList {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Outdent Property

Returns a ToolbarButton with Outdent JavaScript functions builtin

public static ToolbarButton Outdent {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.ParagraphMenu Property

Returns a ToolbarDropDownList with ParagraphMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList ParagraphMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Paste Property

Returns a ToolbarButton with Paste JavaScript functions builtin

public static ToolbarButton Paste {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Print Property

Returns a ToolbarButton with Print JavaScript functions builtin

public static ToolbarButton Print {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Redo Property

Returns a ToolbarButton with Redo JavaScript functions builtin

public static ToolbarButton Redo {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.RemoveFormat Property

Returns a ToolbarButton with RemoveFormat JavaScript functions builtin

public static ToolbarButton RemoveFormat {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Save Property

Returns a ToolbarButton with Save JavaScript functions builtin

public static ToolbarButton Save {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Separator Property

Returns a ToolbarSeparator

public static ToolbarSeparator Separator {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Strikethrough Property

Returns a ToolbarButton with Strikethrough JavaScript functions builtin

public static ToolbarButton Strikethrough {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.StyleMenu Property

Returns a ToolbarDropDownList with StyleMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList StyleMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Subscript Property

Returns a ToolbarButton with Subscript JavaScript functions builtin

public static ToolbarButton Subscript {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Superscript Property

Returns a ToolbarButton with Superscript JavaScript functions builtin

public static ToolbarButton Superscript {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.SymbolsMenu Property

Returns a ToolbarDropDownList with SymbolsMenu JavaScript functions builtin. Items will be filled by FreeTextBox.FillEmptyDefaultDropDowns.

public static ToolbarDropDownList SymbolsMenu {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Underline Property

Returns a ToolbarButton with Underline JavaScript functions builtin

public static ToolbarButton Underline {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Undo Property

Returns a ToolbarButton with Undo JavaScript functions builtin

public static ToolbarButton Undo {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.Unlink Property

Returns a ToolbarButton with Unlink JavaScript functions builtin

public static ToolbarButton Unlink {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.WordClean Property

Returns a ToolbarButton with InsertImage JavaScript functions builtin

public static ToolbarButton WordClean {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarItems.WordCount Property

Returns a ToolbarButton with WordCount JavaScript functions builtin

public static ToolbarButton WordCount {get;}

See Also

ToolbarItems Class | ToolbarItems Members | FreeTextBoxControls Namespace


ToolbarListItem Class

A DropDownList Item for a Toolbar

For a list of all members of this type, see ToolbarListItem Members.

System.Object
ToolbarListItem

public class ToolbarListItem

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarListItem Members | FreeTextBoxControls Namespace


ToolbarListItem Members

Public Instance Constructors

ToolbarListItem Overloaded. Initialize a new instance of the ToolbarListItem class.

Public Instance Properties

BackColor | The backcolor of the DropDown item
Name | The name displayed for the DropDown Item
Value | The value of the DropDown item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarListItem Class | FreeTextBoxControls Namespace


ToolbarListItem Constructor

Initializes a new instance of the ToolbarListItem class.

Overload List

Initializes a new instance of the ToolbarListItem class.

public ToolbarListItem();

public ToolbarListItem(string,string);

public ToolbarListItem(string,string,Color);

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace


ToolbarListItem Constructor ()

Initializes a new instance of the ToolbarListItem class.

public ToolbarListItem();

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace | ToolbarListItem Constructor Overload List


ToolbarListItem Constructor (String, String)

public ToolbarListItem(
string name,
string theValue
);

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace | ToolbarListItem Constructor Overload List


ToolbarListItem Constructor (String, String, Color)

public ToolbarListItem(
string name,
string theValue,
Color backColor
);

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace | ToolbarListItem Constructor Overload List


ToolbarListItem Properties

The properties of the ToolbarListItem class are listed below. For a complete list of ToolbarListItem class members, see the ToolbarListItem Members topic.

Public Instance Properties

BackColor | The backcolor of the DropDown item
Name | The name displayed for the DropDown Item
Value | The value of the DropDown item

See Also

ToolbarListItem Class | FreeTextBoxControls Namespace


ToolbarListItem.BackColor Property

The backcolor of the DropDown item

public System.Drawing.Color BackColor {get; set;}

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace


ToolbarListItem.Name Property

The name displayed for the DropDown Item

public string Name {get; set;}

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace


ToolbarListItem.Value Property

The value of the DropDown item

public string Value {get; set;}

See Also

ToolbarListItem Class | ToolbarListItem Members | FreeTextBoxControls Namespace


ToolbarSeparator Class

Creates a separator bar in a Toolbar

For a list of all members of this type, see ToolbarSeparator Members.

System.Object
ToolbarItem
ToolbarSeparator

public class ToolbarSeparator : ToolbarItem

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarSeparator Members | FreeTextBoxControls Namespace


ToolbarSeparator Members

Public Instance Constructors

ToolbarSeparator Constructor Empty Constructor

Public Instance Properties

CommandIdentifier (inherited from ToolbarItem) | The MSHTML specific command identifier used for dynamic updating through the queryCommandState method
Function (inherited from ToolbarItem) | The javascript function fired when the item's action is triggered
Height (inherited from ToolbarItem) | Button Height
Name (inherited from ToolbarItem) | The Name of the ToolbarItem
ScriptBlock (inherited from ToolbarItem) | The JavaScript code for the function
ScriptBlockBasic (inherited from ToolbarItem) | The JavaScript used for the simple editor for Netscape and IE4
Title (inherited from ToolbarItem) | The Title of the ToolbarItem
Visible (inherited from ToolbarItem) | Whether the item is visible
Width (inherited from ToolbarItem) | Button Width

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarSeparator Class | FreeTextBoxControls Namespace


ToolbarSeparator Constructor

Empty Constructor

public ToolbarSeparator();

See Also

ToolbarSeparator Class | ToolbarSeparator Members | FreeTextBoxControls Namespace


ToolbarType Enumeration

Determines how the toolbars and its buttons and dropdownlists are displayed

public enum ToolbarType

Members

Member Name | Description
OfficeXP | Sets images, borders and backcolors to Office XP style
Office2000 | Sets images, borders and backcolors to Office 2000 style
Office2003 | Sets images, borders and backcolors to Office 2003 style
Custom | You must use this setting if you want custom colors. Otherwise the other settings will override your settings.

Requirements

Namespace: FreeTextBoxControls Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxControls Namespace


FreeTextBoxControls.Common

FreeTextBox 1.6.x

FreeTextBoxControls.Common Namespace

Classes

Class | Description
PostProcessor | Handles HTML processing
ToolbarDropDownListItems | Collection for ToolbarDropDownList
ToolbarItemsList | Collection of ToolbarItems for Toolbar
ToolbarList | Collection of Toolbars


PostProcessor Class

Handles HTML processing

For a list of all members of this type, see PostProcessor Members.

System.Object
PostProcessor

public class PostProcessor

Requirements

Namespace: FreeTextBoxControls.Common Namespace

Assembly: FreeTextBox.dll

See Also

PostProcessor Members | FreeTextBoxControls.Common Namespace


PostProcessor Members

Public Instance Constructors

PostProcessor Constructor Initializes a new instance of the PostProcessor class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HtmlCodesToHtmlSymbols | Converts Html Codes to Html Characters
HtmlSymbolsToHtmlCodes | Converts Html Symbols to their respective Html Codes
RemoveScriptNameFromBookmarks | Removes the scriptname from bookmarks (#mark).
RemoveServerNameFromUrls | Removes the local servername from A and IMG tags
ToString | Outputs a table of all available HMTL Characters

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostProcessor Class | FreeTextBoxControls.Common Namespace


PostProcessor Constructor

Initializes a new instance of the PostProcessor class.

public PostProcessor();

See Also

PostProcessor Class | PostProcessor Members | FreeTextBoxControls.Common Namespace


PostProcessor Methods

The methods of the PostProcessor class are listed below. For a complete list of PostProcessor class members, see the PostProcessor Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
HtmlCodesToHtmlSymbols | Converts Html Codes to Html Characters
HtmlSymbolsToHtmlCodes | Converts Html Symbols to their respective Html Codes
RemoveScriptNameFromBookmarks | Removes the scriptname from bookmarks (#mark).
RemoveServerNameFromUrls | Removes the local servername from A and IMG tags
ToString | Outputs a table of all available HMTL Characters

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostProcessor Class | FreeTextBoxControls.Common Namespace


PostProcessor.HtmlCodesToHtmlSymbols Method

Converts Html Codes to Html Characters

public string HtmlCodesToHtmlSymbols(
string input
);

See Also

PostProcessor Class | PostProcessor Members | FreeTextBoxControls.Common Namespace


PostProcessor.HtmlSymbolsToHtmlCodes Method

Converts Html Symbols to their respective Html Codes

public string HtmlSymbolsToHtmlCodes(
string input
);

See Also

PostProcessor Class | PostProcessor Members | FreeTextBoxControls.Common Namespace


PostProcessor.RemoveScriptNameFromBookmarks Method

Removes the scriptname from bookmarks (#mark).

public string RemoveScriptNameFromBookmarks(
string input,
string serverName,
string url,
string qString
);

See Also

PostProcessor Class | PostProcessor Members | FreeTextBoxControls.Common Namespace


PostProcessor.RemoveServerNameFromUrls Method

Removes the local servername from A and IMG tags

public string RemoveServerNameFromUrls(
string input,
string servername
);

See Also

PostProcessor Class | PostProcessor Members | FreeTextBoxControls.Common Namespace


PostProcessor.ToString Method

Outputs a table of all available HMTL Characters

public override string ToString();

See Also

PostProcessor Class | PostProcessor Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems Class

Collection for ToolbarDropDownList

For a list of all members of this type, see ToolbarDropDownListItems Members.

System.Object
ToolbarDropDownListItems

public class ToolbarDropDownListItems : IEnumerator, IEnumerable

Requirements

Namespace: FreeTextBoxControls.Common Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems Members

Public Instance Constructors

ToolbarDropDownListItems Constructor Initializes a new instance of the ToolbarDropDownListItems class.

Public Instance Properties

Count
Current
Item

Public Instance Methods

Add |
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarDropDownListItems Class | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems Constructor

Initializes a new instance of the ToolbarDropDownListItems class.

public ToolbarDropDownListItems();

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems Properties

The properties of the ToolbarDropDownListItems class are listed below. For a complete list of ToolbarDropDownListItems class members, see the ToolbarDropDownListItems Members topic.

Public Instance Properties

Count
Current
Item

See Also

ToolbarDropDownListItems Class | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Count Property

public int Count {get;}

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Item Property

public FreeTextBoxControls.ToolbarListItem this[
int index
] {get; set;}

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems Methods

The methods of the ToolbarDropDownListItems class are listed below. For a complete list of ToolbarDropDownListItems class members, see the ToolbarDropDownListItems Members topic.

Public Instance Methods

Add |
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarDropDownListItems Class | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Add Method

public void Add(
ToolbarListItem item
);

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Clear Method

public void Clear();

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.MoveNext Method

public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Remove Method

public void Remove(
ToolbarListItem item
);

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarDropDownListItems.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

ToolbarDropDownListItems Class | ToolbarDropDownListItems Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList Class

Collection of ToolbarItems for Toolbar

For a list of all members of this type, see ToolbarItemsList Members.

System.Object
ToolbarItemsList

public class ToolbarItemsList : IEnumerator, IEnumerable

Requirements

Namespace: FreeTextBoxControls.Common Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList Members

Public Instance Constructors

ToolbarItemsList Constructor Initializes a new instance of the ToolbarItemsList class.

Public Instance Properties

Count |
Current |
Item | The Items (ToolbarButton, ToolbarDropDownList, ToolbarSeparator) in the toolbar

Public Instance Methods

Add |
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarItemsList Class | FreeTextBoxControls.Common Namespace


ToolbarItemsList Constructor

Initializes a new instance of the ToolbarItemsList class.

public ToolbarItemsList();

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList Properties

The properties of the ToolbarItemsList class are listed below. For a complete list of ToolbarItemsList class members, see the ToolbarItemsList Members topic.

Public Instance Properties

Count |
Current |
Item | The Items (ToolbarButton, ToolbarDropDownList, ToolbarSeparator) in the toolbar

See Also

ToolbarItemsList Class | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Count Property

public int Count {get;}

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Item Property

The Items (ToolbarButton, ToolbarDropDownList, ToolbarSeparator) in the toolbar

public FreeTextBoxControls.ToolbarItem this[
int index
] {get; set;}

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList Methods

The methods of the ToolbarItemsList class are listed below. For a complete list of ToolbarItemsList class members, see the ToolbarItemsList Members topic.

Public Instance Methods

Add |
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarItemsList Class | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Add Method

public void Add(
ToolbarItem item
);

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Clear Method

public void Clear();

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.MoveNext Method

public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Remove Method

public void Remove(
ToolbarListItem item
);

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarItemsList.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

ToolbarItemsList Class | ToolbarItemsList Members | FreeTextBoxControls.Common Namespace


ToolbarList Class

Collection of Toolbars

For a list of all members of this type, see ToolbarList Members.

System.Object
ToolbarList

public class ToolbarList : IEnumerator, IEnumerable

Requirements

Namespace: FreeTextBoxControls.Common Namespace

Assembly: FreeTextBox.dll

See Also

ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList Members

Public Instance Constructors

ToolbarList Constructor Initializes a new instance of the ToolbarList class.

Public Instance Properties

Count
Current
Item

Public Instance Methods

Add |
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarList Class | FreeTextBoxControls.Common Namespace


ToolbarList Constructor

Initializes a new instance of the ToolbarList class.

public ToolbarList();

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList Properties

The properties of the ToolbarList class are listed below. For a complete list of ToolbarList class members, see the ToolbarList Members topic.

Public Instance Properties

Count
Current
Item

See Also

ToolbarList Class | FreeTextBoxControls.Common Namespace


ToolbarList.Count Property

public int Count {get;}

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.Item Property

public FreeTextBoxControls.Toolbar this[
int index
] {get; set;}

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList Methods

The methods of the ToolbarList class are listed below. For a complete list of ToolbarList class members, see the ToolbarList Members topic.

Public Instance Methods

Add |
Clear |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveNext |
Remove |
Reset |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ToolbarList Class | FreeTextBoxControls.Common Namespace


ToolbarList.Add Method

public void Add(
Toolbar item
);

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.Clear Method

public void Clear();

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.MoveNext Method

public bool MoveNext();

Implements

IEnumerator.MoveNext

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.Remove Method

public void Remove(
Toolbar item
);

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


ToolbarList.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

ToolbarList Class | ToolbarList Members | FreeTextBoxControls.Common Namespace


FreeTextBoxControls.Design

FreeTextBox 1.6.x

FreeTextBoxControls.Design Namespace

Classes

Class | Description
FreeTextBoxDesigner |


FreeTextBoxDesigner Class

For a list of all members of this type, see FreeTextBoxDesigner Members.

System.Object
ComponentDesigner
HtmlControlDesigner
ControlDesigner
FreeTextBoxDesigner

public class FreeTextBoxDesigner : ControlDesigner

Requirements

Namespace: FreeTextBoxControls.Design Namespace

Assembly: FreeTextBox.dll

See Also

FreeTextBoxDesigner Members | FreeTextBoxControls.Design Namespace


FreeTextBoxDesigner Members

Public Instance Constructors

FreeTextBoxDesigner Constructor Initializes a new instance of the FreeTextBoxDesigner class.

Public Instance Properties

AllowResize (inherited from ControlDesigner)
AssociatedComponents (inherited from ComponentDesigner)
Behavior (inherited from HtmlControlDesigner)
Component (inherited from ComponentDesigner)
DataBindings (inherited from HtmlControlDesigner)
DesignTimeHtmlRequiresLoadComplete (inherited from ControlDesigner)
ID (inherited from ControlDesigner)
IsDirty (inherited from ControlDesigner)
ReadOnly (inherited from ControlDesigner)
ShouldCodeSerialize (inherited from HtmlControlDesigner)
Verbs (inherited from ComponentDesigner)

Public Instance Methods

Dispose (inherited from ComponentDesigner) |
DoDefaultAction (inherited from ComponentDesigner) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDesignTimeHtml |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInnerHtml (inherited from ControlDesigner) |
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeNonDefault (inherited from ComponentDesigner) |
IsPropertyBound (inherited from ControlDesigner) |
OnComponentChanged (inherited from ControlDesigner) |
OnSetComponentDefaults (inherited from ComponentDesigner) |
OnSetParent (inherited from HtmlControlDesigner) |
RaiseResizeEvent (inherited from ControlDesigner) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDesignTimeHtml (inherited from ControlDesigner) |

Protected Instance Properties

DesignTimeElement (inherited from HtmlControlDesigner)
DesignTimeElementView (inherited from ControlDesigner)
InheritanceAttribute (inherited from ComponentDesigner)
Inherited (inherited from ComponentDesigner)
ShadowProperties (inherited from ComponentDesigner)

Protected Instance Methods

CreatePlaceHolderDesignTimeHtml (inherited from ControlDesigner) |
CreatePlaceHolderDesignTimeHtml (inherited from ControlDesigner) |
Dispose (inherited from HtmlControlDesigner) |
Finalize (inherited from ComponentDesigner) |
GetEmptyDesignTimeHtml (inherited from ControlDesigner) |
GetErrorDesignTimeHtml (inherited from ControlDesigner) |
GetService (inherited from ComponentDesigner) |
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBehaviorAttached (inherited from ControlDesigner) |
OnBehaviorDetaching (inherited from HtmlControlDesigner) |
OnBindingsCollectionChanged (inherited from ControlDesigner) |
OnControlResize (inherited from ControlDesigner) |
PostFilterAttributes (inherited from ComponentDesigner) |
PostFilterEvents (inherited from ComponentDesigner) |
PostFilterProperties (inherited from ComponentDesigner) |
PreFilterAttributes (inherited from ComponentDesigner) |
PreFilterEvents (inherited from HtmlControlDesigner) |
PreFilterProperties (inherited from ControlDesigner) |
RaiseComponentChanged (inherited from ComponentDesigner) |
RaiseComponentChanging (inherited from ComponentDesigner) |

Explicit Interface Implementations

IDesignerFilter.PostFilterAttributes (inherited from ComponentDesigner)
IDesignerFilter.PostFilterEvents (inherited from ComponentDesigner)
IDesignerFilter.PostFilterProperties (inherited from ComponentDesigner)
IDesignerFilter.PreFilterAttributes (inherited from ComponentDesigner)
IDesignerFilter.PreFilterEvents (inherited from ComponentDesigner)
IDesignerFilter.PreFilterProperties (inherited from ComponentDesigner)

See Also

FreeTextBoxDesigner Class | FreeTextBoxControls.Design Namespace


FreeTextBoxDesigner Constructor

Initializes a new instance of the FreeTextBoxDesigner class.

public FreeTextBoxDesigner();

See Also

FreeTextBoxDesigner Class | FreeTextBoxDesigner Members | FreeTextBoxControls.Design Namespace


FreeTextBoxDesigner Methods

The methods of the FreeTextBoxDesigner class are listed below. For a complete list of FreeTextBoxDesigner class members, see the FreeTextBoxDesigner Members topic.

Public Instance Methods

Dispose (inherited from ComponentDesigner) |
DoDefaultAction (inherited from ComponentDesigner) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetDesignTimeHtml |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetPersistInnerHtml (inherited from ControlDesigner) |
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize |
InitializeNonDefault (inherited from ComponentDesigner) |
IsPropertyBound (inherited from ControlDesigner) |
OnComponentChanged (inherited from ControlDesigner) |
OnSetComponentDefaults (inherited from ComponentDesigner) |
OnSetParent (inherited from HtmlControlDesigner) |
RaiseResizeEvent (inherited from ControlDesigner) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDesignTimeHtml (inherited from ControlDesigner) |

Protected Instance Methods

CreatePlaceHolderDesignTimeHtml (inherited from ControlDesigner) |
CreatePlaceHolderDesignTimeHtml (inherited from ControlDesigner) |
Dispose (inherited from HtmlControlDesigner) |
Finalize (inherited from ComponentDesigner) |
GetEmptyDesignTimeHtml (inherited from ControlDesigner) |
GetErrorDesignTimeHtml (inherited from ControlDesigner) |
GetService (inherited from ComponentDesigner) |
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
OnBehaviorAttached (inherited from ControlDesigner) |
OnBehaviorDetaching (inherited from HtmlControlDesigner) |
OnBindingsCollectionChanged (inherited from ControlDesigner) |
OnControlResize (inherited from ControlDesigner) |
PostFilterAttributes (inherited from ComponentDesigner) |
PostFilterEvents (inherited from ComponentDesigner) |
PostFilterProperties (inherited from ComponentDesigner) |
PreFilterAttributes (inherited from ComponentDesigner) |
PreFilterEvents (inherited from HtmlControlDesigner) |
PreFilterProperties (inherited from ControlDesigner) |
RaiseComponentChanged (inherited from ComponentDesigner) |
RaiseComponentChanging (inherited from ComponentDesigner) |

Explicit Interface Implementations

IDesignerFilter.PostFilterAttributes (inherited from ComponentDesigner)
IDesignerFilter.PostFilterEvents (inherited from ComponentDesigner)
IDesignerFilter.PostFilterProperties (inherited from ComponentDesigner)
IDesignerFilter.PreFilterAttributes (inherited from ComponentDesigner)
IDesignerFilter.PreFilterEvents (inherited from ComponentDesigner)
IDesignerFilter.PreFilterProperties (inherited from ComponentDesigner)

See Also

FreeTextBoxDesigner Class | FreeTextBoxControls.Design Namespace


FreeTextBoxDesigner.GetDesignTimeHtml Method

public override string GetDesignTimeHtml();

See Also

FreeTextBoxDesigner Class | FreeTextBoxDesigner Members | FreeTextBoxControls.Design Namespace


FreeTextBoxDesigner.Initialize Method

public override void Initialize(
IComponent component
);

Implements

IDesigner.Initialize

See Also

FreeTextBoxDesigner Class | FreeTextBoxDesigner Members | FreeTextBoxControls.Design Namespace